const regex = /^(?<AC>\d{3})(?<First>\d{3})(?<Last>\d{4})\s(?<EXT>(E?X?T?e?x?t?\.?\s?\d{1,7})?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<AC>\\d{3})(?<First>\\d{3})(?<Last>\\d{4})\\s(?<EXT>(E?X?T?e?x?t?\\.?\\s?\\d{1,7})?)', 'gm')
const str = `5133521652 extension 1234
5133521652 Extension 1234
5133521652 extension 1234
5133521652 e 1234
5133521652 x 1234
5133521652 t 1234
5133521652 ex 1234
5133521652 ext 1234
5133521652 E 1234
5133521652 X 1234
5133521652 T 1234
5133521652 e. 1234
5133521652 X 1234
5133521652 Ext 1234
5133521652 EXT 1234
5133521652 EXT. 1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}