#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""url":"(.*?)","text":"(.*?)""
Local $sString = "Есть js файл в нем объекты:" & @CRLF & _
"....{" & @CRLF & _
""test":{"url":"https://domain.ru/","text":"name","params":{}},"test":{"url":"https://domain2.ru/","text":"name2","params":{}}," & @CRLF & _
"}..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")