import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"url\":\"(.*?)\",\"text\":\"(.*?)\"";
final String string = "Есть js файл в нем объекты:\n"
+ "....{\n"
+ "\"test\":{\"url\":\"https://domain.ru/\",\"text\":\"name\",\"params\":{}},\"test\":{\"url\":\"https://domain2.ru/\",\"text\":\"name2\",\"params\":{}},\n"
+ "}...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}