using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""url"":""(.*?)"",""text"":""(.*?)""";
string input = @"Есть js файл в нем объекты:
....{
""test"":{""url"":""https://domain.ru/"",""text"":""name"",""params"":{}},""test"":{""url"":""https://domain2.ru/"",""text"":""name2"",""params"":{}},
}...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}