package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"url":"(.*?)","text":"(.*?)"`)
var str = `Есть js файл в нем объекты:
....{
"test":{"url":"https://domain.ru/","text":"name","params":{}},"test":{"url":"https://domain2.ru/","text":"name2","params":{}},
}...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}