#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*?(?<!0)000(?!0))[01]+$"
Local $sString = "100100" & @CRLF & _
"1000100" & @CRLF & _
"00100" & @CRLF & _
"000100" & @CRLF & _
"0000100" & @CRLF & _
"111000" & @CRLF & _
"11100001" & @CRLF & _
"101111000" & @CRLF & _
"00001000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")