import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*?(?<!0)000(?!0))[01]+$";
final String string = "100100\n"
+ "1000100\n"
+ "00100\n"
+ "000100\n"
+ "0000100\n"
+ "111000\n"
+ "11100001\n"
+ "101111000\n"
+ "00001000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}