$re = '/^(?!.*?(?<!0)000(?!0))[01]+$/m';
$str = '100100
1000100
00100
000100
0000100
111000
11100001
101111000
00001000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);