const regex = /^(?!.*?(?<!0)000(?!0))[01]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?(?<!0)000(?!0))[01]+$', 'gm')
const str = `100100
1000100
00100
000100
0000100
111000
11100001
101111000
00001000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}