#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td>((?:(?!<\/td>).)*)<\/td><td>(\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)<\/td>"
Local $sString = "<td>over079</td><td>37.123.86.116</td></tr><tr><td>1346968</td><td>rektheace</td><td></td></tr><tr><td>1346967</td><td>rektheace</td><td>173.245.67.214</td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")