# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td>((?:(?!<\/td>).)*)<\/td><td>(\b\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\b)<\/td>"
test_str = "<td>over079</td><td>37.123.86.116</td></tr><tr><td>1346968</td><td>rektheace</td><td></td></tr><tr><td>1346967</td><td>rektheace</td><td>173.245.67.214</td>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.