import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<td>((?:(?!<\\/td>).)*)<\\/td><td>(\\b\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\b)<\\/td>";
final String string = "<td>over079</td><td>37.123.86.116</td></tr><tr><td>1346968</td><td>rektheace</td><td></td></tr><tr><td>1346967</td><td>rektheace</td><td>173.245.67.214</td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}