package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\.(.*csv)$`)
var str = `12.hello.mp3`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}