use strict;
my $str = '12.hello.mp3';
my $regex = qr/^(\d+)\.(.*csv)$/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";