import re
regex = re.compile(r"^(\d+)\.(.*csv)$", flags=re.MULTILINE)
test_str = "12.hello.mp3"
subst = "\\1 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)