$re = '/^(\d+)\.(.*csv)$/m';
$str = '12.hello.mp3';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;