#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[A-Z])(?![A-Z])|(?<![A-Z])(?=[A-Z])"
Local $sString = "13MAY2022" & @CRLF & _
"13MAY2022" & @CRLF & _
"13MAY2022" & @CRLF & _
"13MAY2022"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)