using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[A-Z])(?![A-Z])|(?<![A-Z])(?=[A-Z])";
string substitution = @" ";
string input = @"13MAY2022
13MAY2022
13MAY2022
13MAY2022";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}