$re = '/(?<=[A-Z])(?![A-Z])|(?<![A-Z])(?=[A-Z])/m';
$str = '13MAY2022
13MAY2022
13MAY2022
13MAY2022';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;