const regex = /(?<=[A-Z])(?![A-Z])|(?<![A-Z])(?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Z])(?![A-Z])|(?<![A-Z])(?=[A-Z])', 'gm')
const str = `13MAY2022
13MAY2022
13MAY2022
13MAY2022`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);