#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{3}\.\d+\.\d+\.\d+"
Local $sString = "The following is an ip address 127.0.0.1" & @CRLF & _
"Use the ip 192.168.33.21 to reach home." & @CRLF & _
"188.25.125.105" & @CRLF & _
"127.0.1.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")