using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}\.\d+\.\d+\.\d+";
string input = @"The following is an ip address 127.0.0.1
Use the ip 192.168.33.21 to reach home.
188.25.125.105
127.0.1.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}