package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{3}\.\d+\.\d+\.\d+`)
var str = `The following is an ip address 127.0.0.1
Use the ip 192.168.33.21 to reach home.
188.25.125.105
127.0.1.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}