use strict;
my $str = 'AJQK2345678910';
my $regex = qr/1?./mp;
my $subst = '\\0H,\\0S,\\0D,\\0C,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";