$re = '/1?./m';
$str = 'AJQK2345678910';
$subst = "\0H,\0S,\0D,\0C,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;