// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)1?.").unwrap();
let string = "AJQK2345678910";
let substitution = "\\0H,\\0S,\\0D,\\0C,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}