import Foundation
let pattern = #"1?."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"AJQK2345678910"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\0H,\0S,\0D,\0C,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)