#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\n(.{90,}[\.\?\:].*){2,}\n$"
Local $sString = "" & @CRLF & _
"Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy]." & @CRLF & _
"" & @CRLF & _
" Materials and Methods" & @CRLF & _
"" & @CRLF & _
" Materials" & @CRLF & _
"" & @CRLF & _
" . Introduction" & @CRLF & _
"" & @CRLF & _
"Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy]." & @CRLF & _
"" & @CRLF & _
" Preparation of The Ecosystem" & @CRLF & _
"" & @CRLF & _
"Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Hello world. " & @CRLF & _
"" & @CRLF & _
" Hello world" & @CRLF & _
"" & @CRLF & _
"Figure 2a: Alterations to a bunch of test text that's written in a hurry. We can add as much text as we want to this one (this tye of text doesn't appear in my documents, where we have a sentence break : v early on)." & @CRLF & _
"" & @CRLF & _
" Thing Components " & @CRLF & _
"These images show the initial and final stages of the thing constituents. " & @CRLF & _
"Figure 3a" & @CRLF & _
"Figure 3f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")