re = /^\n(.{90,}[\.\?\:].*){2,}\n$/mi
str = '
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].
Materials and Methods
Materials
. Introduction
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].
Preparation of The Ecosystem
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Hello world.
Hello world
Figure 2a: Alterations to a bunch of test text that\'s written in a hurry. We can add as much text as we want to this one (this tye of text doesn\'t appear in my documents, where we have a sentence break : v early on).
Thing Components
These images show the initial and final stages of the thing constituents.
Figure 3a
Figure 3f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end