use strict;
my $str = '
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].
Materials and Methods
Materials
. Introduction
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].
Preparation of The Ecosystem
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Hello world.
Hello world
Figure 2a: Alterations to a bunch of test text that\'s written in a hurry. We can add as much text as we want to this one (this tye of text doesn\'t appear in my documents, where we have a sentence break : v early on).
Thing Components
These images show the initial and final stages of the thing constituents.
Figure 3a
Figure 3f';
my $regex = qr/^\n(.{90,}[\.\?\:].*){2,}\n$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}