import Foundation
let pattern = #"^\n(.{90,}[\.\?\:].*){2,}\n$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].
Materials and Methods
Materials
. Introduction
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].
Preparation of The Ecosystem
Quantifier: {2,} Between 2 and unlimited times, as many times as possible, giving back as needed [greedy].Hello world.
Hello world
Figure 2a: Alterations to a bunch of test text that's written in a hurry. We can add as much text as we want to this one (this tye of text doesn't appear in my documents, where we have a sentence break : v early on).
Thing Components
These images show the initial and final stages of the thing constituents.
Figure 3a
Figure 3f
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)