using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?:\[tab\s # looks for [tab + whitespace literally
| # or
(?!\A)\G\s) # (?!\A) = negative lookahead
# to make sure the following is not the start
# of the string
# \G matches at the end of the previous match
(?P<key>\w+) # match a word character greedily to group ""key""
=
""(?P<value>[^""]+)"" # "" + anything not "" + "", save this to group ""value""
";
string input = @"some gibberish here [tab title=""Emergency Contact"" important=""true""] some additional info here";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}