$re = '~ (?:\[tab\s # looks for [tab + whitespace literally
| # or
(?!\A)\G\s) # (?!\A) = negative lookahead
# to make sure the following is not the start
# of the string
# \G matches at the end of the previous match
(?P<key>\w+) # match a word character greedily to group "key"
=
"(?P<value>[^"]+)" # " + anything not " + ", save this to group "value"
~x';
$str = 'some gibberish here [tab title="Emergency Contact" important="true"] some additional info here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);