const regex = new RegExp(' (?:\\[tab\\s # looks for [tab + whitespace literally
| # or
(?!\\A)\\G\\s) # (?!\\A) = negative lookahead
# to make sure the following is not the start
# of the string
# \\G matches at the end of the previous match
(?P<key>\\w+) # match a word character greedily to group "key"
=
"(?P<value>[^"]+)" # " + anything not " + ", save this to group "value"
', 'g')
const str = `some gibberish here [tab title="Emergency Contact" important="true"] some additional info here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}