import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?:\\[tab\\s # looks for [tab + whitespace literally\n"
+ " | # or\n"
+ " (?!\\A)\\G\\s) # (?!\\A) = negative lookahead\n"
+ " # to make sure the following is not the start\n"
+ " # of the string\n"
+ " # \\G matches at the end of the previous match\n"
+ " (?P<key>\\w+) # match a word character greedily to group \"key\"\n"
+ " =\n"
+ " \"(?P<value>[^\"]+)\" # \" + anything not \" + \", save this to group \"value\"\n"
+ " ";
final String string = "some gibberish here [tab title=\"Emergency Contact\" important=\"true\"] some additional info here";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}