import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<link.*?href=(.))[^\"']+\\.css([^\"']+\\2[^>]*?>)";
final String string = "<link rel=\"stylesheet\" type=\"text/css\" href=\"//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c\">\n"
+ "<link type=\"text/css\" rel=\"stylesheet\" href=\"//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c\" >\n"
+ "<link href=\"//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c\" type=\"text/css\" rel=\"stylesheet\">";
final String subst = "$1new.css$3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}