use strict;
my $str = '<link rel="stylesheet" type="text/css" href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c">
<link type="text/css" rel="stylesheet" href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c" >
<link href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c" type="text/css" rel="stylesheet">';
my $regex = qr/(<link.*?href=(.))[^"']+\.css([^"']+\2[^>]*?>)/ip;
my $subst = '$1new.css$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";