import Foundation
let pattern = #"(<link.*?href=(.))[^"']+\.css([^"']+\2[^>]*?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<link rel="stylesheet" type="text/css" href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c">
<link type="text/css" rel="stylesheet" href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c" >
<link href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c" type="text/css" rel="stylesheet">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1new.css$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)