$re = '/(<link.*?href=(.))[^"\']+\.css([^"\']+\2[^>]*?>)/i';
$str = '<link rel="stylesheet" type="text/css" href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c">
<link type="text/css" rel="stylesheet" href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c" >
<link href="//cdn.sstatic.net/stackoverflow/all.css?v=93e7a6733c8c" type="text/css" rel="stylesheet">';
$subst = "$1new.css$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;