import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*\\.?\\d+)(?:\\(g\\/\\d*ml\\)|g?\\b)";
final String string = "0\n"
+ "1\n"
+ "0.1\n"
+ ".1\n"
+ "1g\n"
+ "0.1g\n"
+ ".1g\n"
+ "1(g/100ml)\n"
+ ".1(g/ml)\n\n"
+ "1abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}