// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)(\d*\.?\d+)(?:\(g\/\d*ml\)|g?\b)").unwrap();
  let string = "0
1
0.1
.1
1g
0.1g
.1g
1(g/100ml)
.1(g/ml)
1abc";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}