re = /(\d*\.?\d+)(?:\(g\/\d*ml\)|g?\b)/m
str = '0
1
0.1
.1
1g
0.1g
.1g
1(g/100ml)
.1(g/ml)
1abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end