#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(DV|DoVi|Dolby[ .]?Vision)[ .]?HDR10(\+|(?:[ .]?PLUS|[ .]?Plus)\b)"
Local $sString = "DV HDR10+" & @CRLF & _
"DV.HDR10+" & @CRLF & _
"DV HDR10PLUS" & @CRLF & _
"DV.HDR10PLUS" & @CRLF & _
"DV HDR10.PLUS" & @CRLF & _
"DV.HDR10.PLUS" & @CRLF & _
"DV HDR10 PLUS" & @CRLF & _
"DV.HDR10 PLUS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")