package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(DV|DoVi|Dolby[ .]?Vision)[ .]?HDR10(\+|(?:[ .]?PLUS|[ .]?Plus)\b)`)
var str = `DV HDR10+
DV.HDR10+
DV HDR10PLUS
DV.HDR10PLUS
DV HDR10.PLUS
DV.HDR10.PLUS
DV HDR10 PLUS
DV.HDR10 PLUS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}