// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(DV|DoVi|Dolby[ .]?Vision)[ .]?HDR10(\+|(?:[ .]?PLUS|[ .]?Plus)\b)").unwrap();
let string = "DV HDR10+
DV.HDR10+
DV HDR10PLUS
DV.HDR10PLUS
DV HDR10.PLUS
DV.HDR10.PLUS
DV HDR10 PLUS
DV.HDR10 PLUS";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}