$re = '/\b(DV|DoVi|Dolby[ .]?Vision)[ .]?HDR10(\+|(?:[ .]?PLUS|[ .]?Plus)\b)/m';
$str = 'DV HDR10+
DV.HDR10+
DV HDR10PLUS
DV.HDR10PLUS
DV HDR10.PLUS
DV.HDR10.PLUS
DV HDR10 PLUS
DV.HDR10 PLUS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);