const regex = /<([^\/> ]+)\s*([^>]*)\s*(?:\/>|>(.*)<\/\1>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([^\\\/> ]+)\\s*([^>]*)\\s*(?:\\\/>|>(.*)<\\\/\\1>)', 'g')
const str = `<tag attrib="text" attrib2 = "othertext"><innertag>value</innertag></tag>
<tag2 />
<tag3/>
<tag4>value</tag4>
<tag5></tag5>
<tag2 attrib="text" attrib2 = "othertext" />
<tag3 attrib="text" attrib2 = "othertext"/>
<tag5 attrib="text" attrib2 = "othertext"></tag5>
<([^\\/> ]+)\\s*([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>) (with global) finds all tags in scope
1st group is tagname
2nd group is attributes
3rd group (if it exists) is value of the tag
Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)
Apply pattern below on 2nd group to find all attributes:
\\s+([^<>\\=" ]+)\\s*=\\s*"([^"]*)" (with global) finds attributes
1st group is attributename
2nd group is attributevalue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}