import re
regex = re.compile(r"<([^\/> ]+)\s*([^>]*)\s*(?:\/>|>(.*)<\/\1>)")
test_str = ("<tag attrib=\"text\" attrib2 = \"othertext\"><innertag>value</innertag></tag>\n"
"<tag2 />\n"
"<tag3/>\n"
"<tag4>value</tag4>\n"
"<tag5></tag5>\n"
"<tag2 attrib=\"text\" attrib2 = \"othertext\" />\n"
"<tag3 attrib=\"text\" attrib2 = \"othertext\"/>\n"
"<tag5 attrib=\"text\" attrib2 = \"othertext\"></tag5>\n\n\n\n"
"<([^\\/> ]+)\\s*([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>) (with global) finds all tags in scope\n\n"
"1st group is tagname\n"
"2nd group is attributes\n"
"3rd group (if it exists) is value of the tag\n\n"
"Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)\n\n\n"
"Apply pattern below on 2nd group to find all attributes:\n\n"
"\\s+([^<>\\=\" ]+)\\s*=\\s*\"([^\"]*)\" (with global) finds attributes\n\n"
" 1st group is attributename\n"
" 2nd group is attributevalue")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")