use strict;
my $str = '<tag attrib="text" attrib2 = "othertext"><innertag>value</innertag></tag>
<tag2 />
<tag3/>
<tag4>value</tag4>
<tag5></tag5>
<tag2 attrib="text" attrib2 = "othertext" />
<tag3 attrib="text" attrib2 = "othertext"/>
<tag5 attrib="text" attrib2 = "othertext"></tag5>
<([^\\/> ]+)\\s*([^>]*)\\s*(?:\\/>|>(.*)<\\/\\1>) (with global) finds all tags in scope
1st group is tagname
2nd group is attributes
3rd group (if it exists) is value of the tag
Apply pattern again on 3th group to find internal tags (recurse in the code to parse entire xml!)
Apply pattern below on 2nd group to find all attributes:
\\s+([^<>\\=" ]+)\\s*=\\s*"([^"]*)" (with global) finds attributes
1st group is attributename
2nd group is attributevalue';
my $regex = qr/<([^\/> ]+)\s*([^>]*)\s*(?:\/>|>(.*)<\/\1>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}