#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^=\n\r]+?)\s*=\s*(\{([^}]*)\}|.*)"
Local $sString = "[Group Variable]" & @CRLF & _
"name = Value" & @CRLF & _
"" & @CRLF & _
"[Valid Extensions]" & @CRLF & _
"images = {" & @CRLF & _
"jpeg" & @CRLF & _
"png" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")